Excel Datenüberprüfung: Eingabe doppelter Werte verhindern und mit einer Fehlermeldung abfangen

Im Tipp „Excel Duplikate und Dubletten: Doppelte Werte finden und löschen“ haben wir bereits beschrieben, wie Sie doppelte Werte im Handumdrehen entfernen. Besser ist es natürlich, es erst gar nicht so weit kommen zu lassen. In vielen Tabellen dürfen bestimmte Einträge nur einmal vorkommen, etwa Auftrags- oder Rechnungsnummern. Um von vornherein Doppler zu verhindern, hilft eine Gültigkeitsprüfung.

Doppelte Werte erst gar nicht zulassen

Mit folgenden Schritten unterbinden Sie das Einfügen von Duplikaten:

1. Markieren Sie den Tabellenbereich, in dem es keine Doppler geben darf, etwa die Spalte „Rechnungsnummer“.

2. Bei Excel bis zur Version 2003 rufen Sie den Befehl „Daten | Gültigkeit“ auf und wechseln ins Register „Einstellungen“. Bei Excel 2007/2010/2013 wechseln Sie zum Menüband „Daten“ und klicken im Bereich „Datentools“ auf die Schaltfläche „Datenüberprüfung“.

3. Im Feld „Zulassen“ wählen Sie den Eintrag „Benutzerfediniert“ und tragen folgende Formel ein:

=ZÄHLENWENN($A$2:$A$50;A1)=1

Der Bereich in Klammern gibt an, für welche Zellbereich die Einschränkung gelten sollen, hier (hier A2 bis A50), die Zellkoordinate hinter dem Semikolon gibt die erste Rechnungsnummer in der Spalte an.

4. Wechseln Sie zur Registerkarte „Fehlermeldung“, kreuzen Sie das Kontrollkästchen „Fehlermeldung anzeigen, wenn ungültige Daten eingegeben wurden“ an, und tragen Sie die Fehlermeldung ein.

5. Schließen Sie das Fenster mit OK.

Doppelte Rechnungsnummern können jetzt nicht mehr eingetragen werden. Sobald Excel einen Doppler entdeckt, erscheint die Fehlermeldung.

Kommentar schreiben

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.