Excel-Formeln: Nur jede x-te Zelle auswerten

Bei den meisten Formeln werden ganze Zellbereiche berücksichtigt; bei der Formel =SUMME(A1:A23) etwa der Bereich von Zelle A1 bis A24. Mitunter sollen aber nur die Werte jeder zweiten, dritten oder vierten Zeile addiert werden. Viele Excel-Anwender markieren dann von Hand die betreffenden Zellen. Eine mühsame und zudem überflüssige Notlösung. Denn mit einer geschickten Formelergänzung können Sie die Aufgabe auch automatisch erledigen.

Zauberwort Matrixformel

Das Ganze funktioniert über sogenannte Matrixformeln in Kombination mit weiteren Tabellenfunktionen. Um zum Beispiel jede vierte Zeile im Bereich A1 bis A100 zu summieren, sind folgende Schritte notwendig:

1. Geben Sie in die Zeile, in der das Ergebnis erscheinen soll, folgende Formel ein:

=SUMME(WENN(REST(ZEILE(A1:A100);4)=0;A1:A100;0))

Der Parameter 4 bestimmt, welche Zeilen im angegebenen Zellbereich addiert werden soll – in diesem Beispiel jede vierte Zeile.

2. Wichtig: Schließen Sie die Formel nicht mit [Return], sondern mit der Tastenkombination [Strg][Shift/Umschalten][Return] ab.

Excel erzeugt aus der Formel eine Matrixformel; erkennbar an den geschweiften Klammern. Eine Matrixformel ist eine spezielle Tabellenformel, die wie eine Schleife einer Programmiersprache arbeitet und in diesem Beispiel den Zellbereich durchgeht und nur jede vierte Zelle addiert.

Kommentar schreiben

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.