In einer Excel Spalte die Anzahl verschiedener Werte ermitteln

Excel ist beispielsweise auch dazu geeignet, um die eigene Musiksammlung anzulegen. So können Sie dabei verschieden Spalten für Künstler, Albumtitel oder Erscheinungsdatum anlegen. In der Spalte Künstler kommen dann viele Interpreten doppelt vor, da Sie von diesen mehrere Alben besitzen. Excel bietet mittels einer Formel die Möglichkeit festzustellen, wie viele unterschiedliche Künstler in einer Spalte vorkommen. Benötigt wird dabei eine Formel, die aus einer Vielzahl von Textwerten die Anzahl der unterschiedlichen Werte ausgibt.

Am besten lösen Sie diese Aufgabe mit einer Matrixformel. Mit dieser lassen sich zwei Berechnungsschritte in einer Formel ausführen. Angenommen die Daten, welche Sie auswerten möchten, befinden sich in den Zellbereichen A2 bis A150 würde die betreffende Formel wie folgt aussehen:

=SUMME(WENN(A2:A100=““;0;1/ZÄHLENWENN(A2:A100;A2:A150)))

Um eine Matrixformel korrekt zu erzeugen, ist es wichtig, dass Sie nach Eingabe der Formel nicht die Eingabetaste betätigen. Stattdessen nutzen Sie die Tastenkombination [Strg][Shift/Umschalten][Eingabe], um eine Matrixformel zu erstellen.

Zunächst berechnet die Matrixformel für die angegebenen Zellen von A2 bis A150 das Ergebnis der „Wenn“ Funktion. Zum Schluss wird dann die Summe über alle einzelnen Ergebnisse gebildet.

Falls die Zelle leer ist, liefert die „Wenn“ Funktion das Ergebnis „0“ aus. Befindet sich ein Wert in der Zelle, dann wird durch die Funktion „ZÄHLENWENN“ der entsprechende Zahlenwert ausgegeben. Dabei bleibt der Datenbereich der Funktion stets A2 bis A150, wobei das Kriterium sämtliche Zellen von A2 bis A150 durchläuft. Angenommen der Künstler 3 befindet sich viermal in der Liste so gibt die Funktion „ZÄHLENWENN“ an allen diesen Stellen das Ergebnis „4“ aus. Aufgrund des Kehrwertes geht bei der Bildung der Summe jedoch viermal der Wert 1/4 ein, wobei genau das Ergebnis 1 geliefert wird. Zum Abschluss wird als Summe der Matrixformel das Ergebnis über die gesamte Anzahl der unterschiedlichen Textwerte ermittelt. Im Beispiel wäre dies die Anzahl der unterschiedlichen Künstler, welche sich in Ihrer Musiksammlung befinden.

Kommentar schreiben

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.