Kategorien
Hardware & Software Software

Microsoft Excel: Ostern mit Excel berechnen

Auf welchen Tag fällt Ostersonntag? Das lässt sich auf Anhieb nicht sagen. Denn der bewegliche Feiertag fällt nach dem ersten Konzil von Nicäa aus dem Jahre 325 immer auf den ersten Sonntag nach dem ersten Vollmond des Frühlings. Gut, dass es eine Excel-Formel gibt, mit der Sie Ostern exakt berechnen.

Auf welchen Tag fällt Ostersonntag? Das lässt sich auf Anhieb nicht sagen. Denn der bewegliche Feiertag fällt nach dem ersten Konzil von Nicäa aus dem Jahre 325 immer auf den ersten Sonntag nach dem ersten Vollmond des Frühlings. Gut, dass es eine Excel-Formel gibt, mit der Sie Ostern exakt berechnen.

Grundlage ist die Gauß’sche Osterformel, die der Mathematiker Carl Friedrich Gauß bereits um 1800 entwickelt hat. Zum Glück müssen Sie nicht die komplette Formel auswendig kennen.

excel-logoUm möglichst einfach mit Excel das Osterdatum zu berechnen – zum Beispiel den Ostersonntag -, geben Sie in Zelle A1 das Jahr ein, etwa 2010. Mit der folgenden Formel können Sie dann das Osterdatum berechnen:

=DM((TAG(MINUTE(A1/38)/2+55)&".4."&A1)/7;)*7-6

Sie können die Jahreszahl auch direkt in die Formel einbauen. Für das Jahr 2010 sieht das dann folgendermaßen aus:

=DM((TAG(MINUTE(2010/38)/2+55)&".4."&2010)/7;)*7-6
excel-ostersonntag-ostern-berechnen

Wichtig, damit’s klappt: Ändern Sie das Zellenformat in „Datum“, damit statt der Zahl das korrekte Datum eingetragen wird.

Übrigens: Hat man einmal das Osterdatum ermittelt, lassen sich auch die anderen beweglichen Feiertage Christi Himmelfahrt (Ostersonntag plus 39 Tage) und Pfingstmontag (Ostersonntag + 50 Tage) berechnen.

6 Antworten auf „Microsoft Excel: Ostern mit Excel berechnen“

Eine Formel für 1900-2203, ohne den Fehler für 2079 und die auch im 1904-er Dateiformat funktioniert
=7*DM(((5&-A2)-TAG(9))/7-REST(REST(A2;19)&5;4,225);)+TAG(1)

Die obige Excelformel funktioniert 1900-2203 außer für 2079.
Sie funktioniert auch nur für das 1900-er Datumsformat, für das 1904-er nicht.
Berechnet wird nur für den Gregorianischen Kalender, nicht für den Julianischen Kalender.

Und hier die Excel-Formel fürs Knabenschiessen (lokaler Feiertag in Zürich):

=DATUM(A1; 9; 15)-REST(WOCHENTAG(DATUM(A1; 9; 6); 1); 7)

Fürs Sechseläuten gibt es leider keine Fromel, da der Feiertag u.a. von den Schulferien abhängt. Am besten benutzt man hier „sverweis“ für die nächsten Jahre zusammen mit der untenstehenden Liste:

=SVERWEIS(A1; B1:C7; 2)

B C
2015 13.04.15
2016 18.04.16
2017 24.04.17
2018 16.04.18
2019 08.04.19
2020 20.04.20
2021 19.04.21

Super. Danke für den Zusatztipp zum Berechnen des Buß- und Bettags mit Excel. Klasse.

Ich biete zu dieser genialen Osterformel eine Kurzberechnung für den Buss- und Bettag an:

=(„23.11.“&JAHR(A1))-WOCHENTAG(A1)

in Zelle A1 steht das Datum des 24.12. des Jahres

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.