Kategorien
Excel Hardware & Software

Microsoft Excel: Eigene Fehlermeldungen für den Fehler „#DIV/0“ (Division durch Null)

Der Fehler „#DIV/0“ ist eine der häufigsten und ärgerlichsten Fehlermeldungen. Leider lässt sie sich nicht immer verhindern. Sie können aber dafür sorgen, dass statt des Fehlerkürzels eine eigene Meldung oder Zeichenfolge in der Zelle erscheint.

Statt #DIV/0 einen eigenen Fehlertext definieren

Der Fehler „DIV/0“ tritt schneller auf als einem lieb ist. Wenn zum Beispiel in einer Umsatztabelle die Zelle A2 durch B2 dividiert wird, erscheint der Fehler #DIV/0 immer dann, wenn in Zelle B2 der Wert 0 steht. Mit folgendem Trick ersetzen Sie die Fehlermeldung durch das Kürzel „n.a.“:

1. Klicken Sie doppelt auf die gewünschte Zelle mit der Formel. Im obigen Beispiel lautet die Formel etwa

=A2/B2

excel-fehler-fehlermeldung-div-null-division-durch-null

2. Ersetzen Sie die Formel durch folgende WENN-Abfrage:

=WENN(B2 = 0; „n.a.“; A2/B2)

excel-fehler-fehlermeldung-div-null-division-durch-null-2

Die Abfrage prüft zuerst, ob der Divisor (hier in Zelle B2) Null ist. In diesem Fall erscheint statt der Fehlermeldung der Texthinweis „n.a.“ In allen anderen Fällen wird wie geplant die Rechnung A2/B2 durchgeführt.

excel-fehler-fehlermeldung-div-null-division-durch-null-3

3. Bestätigen Sie die Änderung mit der [Return]-Taste. Der #DIV/0-Fehler gehört damit der Vergangenheit an.

Übrigens: Sie können statt „n.a.“ auch jeden beliebigen anderen Text verwenden. Geben Sie den gewünschten Alterantivtext einfach innerhalb der Anführungszeichen ein. Mit der Wenn-Formel

=WENN(B2 = 0; „0“; A2/B2)

erscheint zum Beispiel die Null (0), sobald der DIV/0-Fehler auftritt. Soll gar kein Alternativtext und nur eine leere Zelle erscheinen, lautet die Formel:

=WENN(B3 = 0; „“; A3/B3)

Kategorien
Excel Hardware & Software

Excel: Fehler verstecken und unsichtbar machen

Bei der Arbeit mit Tabellen und Formeln lassen sich Fehlermeldungen nicht immer vermeiden. In Umsatzstatistiken kommt es zum Beispiel häufig zum Fehler  „#DIV0!“ (Division durch Null), sobald in einer Zeile der Gesamtumsatz durch Null Verkäufe geteilt wird. Der Fehler selbst ist nicht weiter tragisch, stört aber die Optik der Tabelle. Es geht auch schöner. Soll die Tabelle trotz Fehlermeldungen einen aufgeräumten Eindruck hinterlassen, verstecken Sie die Meldungen einfach.

Fehlermeldungen verstecken

Mit folgenden Schritten machen Sie Fehlermeldungen unsichtbar:

1. Markieren Sie die Zelle, in der Fehlermeldungen unsichtbar werden sollen.

2. Bei Excel bis zur Version 2003 rufen Sie den Befehl „Format | Bedingte Formatierung“ auf und wählen im Listenfeld den Eintrag „Formel ist“.

Bei Excel 2007/2010/2013 klicken Sie auf die Schaltfläche „Bedingte Formatierung“ und dann auf „Neue Regel“. Im folgenden Dialogfenster klicken Sie zusätzlich auf „Formel zur Ermittlung der zu formatierenden Zellen verwenden“.

excel-fehler-fehlermeldungen-vermeiden-verstecken-nicht-anzeigen-unsichtbar-machen-bedingte-formatierung

3. Um sämtliche Fehler zu unterdrücken, geben Sie ins Formelfeld folgende Formel ein:

=ISTFEHLER(D2)

excel-fehler-fehlermeldungen-vermeiden-verstecken-nicht-anzeigen-unsichtbar-machen-bedingte-formatierung-2

Die Zahl in Klammern gibt die Koordinate der markierten Zelle an, in diesem Beispiel D2. Ersetzen Sie den Beispielwert durch die Zellkoordinate Ihrer Tabelle.

Statt alle Fehler abzufangen, können Sie sich auch gezielt einzelne Fehler beschränken. Hierzu verwenden Sie eine Formel wie

=FEHLER.TYP(D2)=2

In Klammern wird wieder der Zellbezug angegeben. Die Zahl hinter dem Gleichheitszeichen bestimmt, welcher Fehler gemeint ist. Folgende Werte sind möglich:

FehlerwertWert hinter Gleichheitszeichen
#NULL!1
#DIV/0!2
#WERT!3
#BEZUG!4
#NAME?5
#NV7
Sonstiges#NV

4. Klicken Sie auf die Schaltfläche „Formatieren“, und wählen Sie die Schriftfarbe „Weiß“ aus.

5. Schließen Sie die Fenster mit OK. Der Fehler ist zwar intern noch vorhanden; da die Zelle jedoch mit weißer Schrift auf weißem Grund formatiert wird, ist sie unsichtbar.

6. Im letzten Schritt können Sie die bedingte Formatierung auf die übrigen Zellen übertragen, indem Sie zunächst die zuletzt bearbeitete Zelle (mit der bedingten Formatierung) markieren und mit [STRG][C] in die Zwischenablage kopieren.

7. Dann markieren Sie alle Zellen, bei denen Sie die Fehlermeldungen ausblenden möchten und rufen den Befehl „Bearbeiten | Inhalte einfügen“ auf. Bei Excel 2007/2010/2013  klicken Sie auf den kleinen Pfeil unterhalb der „Einfügen“-Schaltfläche und dann auf „Inhalte einfügen“.

8. Im nächsten Fenster wählen Sie die Option „Formate“ und klicken auf OK. Damit wird nur die bedingte Formatierung auf die markierten Zellen übertragen.

excel-fehler-fehlermeldungen-vermeiden-verstecken-nicht-anzeigen-unsichtbar-machen-bedingte-formatierung-3