Kategorien
Excel Hardware & Software

Excel Summe bilden: Summen über Spalten und Zeilen berechnen

Mit der Summenformel werden üblicherweise nur bestimmte Bereiche einer Tabelle summiert, mit der Formel =SUMME(A1;A20) zum Beispiel alles zwischen den Zellen A1 und A20. Kommen weitere Zeilen hinzu, beginnt die Arbeit von vorne. Erst wenn die Formel angepasst wurde, werden auch die neuen Zeilen berücksichtigt. Das muss nicht sein. Viel einfacher ist es, gleich die Summe über die gesamte Spalte oder Zeile zu bilden. Ob und wie viele Werte hinzukommen, spielt dann keine Rolle – die Summenformel zeigt stets das korrekte Ergebnis.

Eine Formel für die komplette Spalte oder Zeile

Um ganze Spalten oder Zeilen zu addieren, müssen Sie bei der Summenformel keinen Zellbereich, sondern zweimal hintereinander die Spalte bzw. Zeile eintragen. Zum Addieren aller Werte in Spalte C lautet die Formel dann

=SUMME(C:C)

Möchten Sie alle Werte in Zeile 41 summieren, genügt folgende Formel:

=SUMME(41:41)

microsoft-excel-summe-komplette-spalte-komplette-zeile

Kategorien
Excel Hardware & Software

Excel Schnellberechnungen: Summen, Mittelwerte, Minimum, Maximum und vieles mehr ohne Formel berechnen

Zum Rechnen in Tabellen kommen meist Formeln zum Einsatz. Was viele Anwender aber nicht wissen: die gängigsten Berechnungen lassen sich auch ohne Formel durchführen. Wenn Sie auf die Schnelle die Summe eine Zellbereichs, den größten und kleinsten Wert oder die Anzahl der Werte ermitteln möchten, reicht ein Blick in die Statuszeile.

Statuszeile zeigt Rechenergebnisse

Um kleinere Rechenaufgaben wie das Summieren von Zellen ohne Formel zu erledigen, müssen Sie nur die betreffenden Zellen markieren. Entweder markieren Sie mit gedrückter Maustaste einen ganzen Zellbereich oder halten die [Strg]-Taste gedrückt und klicken nacheinander auf beliebige Zellen. Sobald zwei oder mehr Zellen markiert sind, erscheint unten rechts in der Statuszeile die Summe der Zellinhalte. Das ist aber noch nicht alles.

exel-rechenfunktion-in-der-statusleiste-leiste

Wenn Sie mit der rechten Maustaste auf die Summe klicken, erscheint ein Kontextmenü mit weiteren Rechenfunktionen. Hier können Sie selbst festlegen, welche Werte in der Statusleiste angezeigt werden, zum Beispiel der „Mittelwert“, die „Anzahl“ der Werte oder das „Minimum“ und „Maximum“. Für schnelle Ergebnisse zwischendurch eine praktische Sache.

Kategorien
Beruf Excel Finanzen Geld & Finanzen Hardware & Software Heimwerken Hobby Office Software Windows 7 Windows 98 Windows Vista Windows XP

Excel 2003, 2007, 2010: Nullwerte in den Zellen deaktivieren

Manche Formel-Berechnungen mit Excel können das Ergebnis „Null“ ergeben. Das gleiche gilt für formatierte Tabellen, deren Zellen nicht komplett belegt sind. Auch diese werden automatisch mit einer Null ausgefüllt. In den meisten Fällen stört das die Optik der Tabelle. Diese Anzeige von Nullwerten kann man bei Excel ganz einfach bei Bedarf deaktivieren und auch wieder aktivieren.

Bei der Version 2003 klicken Sie bei Excel in der Menüleiste auf „Extras | Optionen“ und wählen die Registerkarte „Allgemein“. Im Bereich „Fensteroptionen“ entfernen Sie das Häkchen bei „Nullwerte“. Zum Bestätigen der Änderung klicken Sie auf „OK“.

Ab Excel Version 2007 klicken Sie im Dateimenü auf „Optionen“, danach im linken Fensterbereich auf „Erweitert“. Unter „Optionen für dieses Arbeitsblatt anzeigen“ deaktivieren Sie die Funktion „In Zellen mit Nullwert eine Null anzeigen“. Die Änderung mit „OK“ bestätigen.

Die Änderung ist sofort wirksam und in dem aktuellen Tabellenblatt werden alle Nullwerte entfernt.