Kategorien
Hardware & Software Office

Open Office Calc: Korrekte Addition von Stunden durchführen

Open Office Calc ist mindestens genau so beliebt wie sein Microsoft Pendant Excel. Viele Funktionen, die man von Excel kennt, sind auch hier vorhanden. Mit allen Vor- und Nachteilen. Zum Beispiel beim Zahlenformat Zeit. Möchtest du mit dieser Formatierung eine Stundensummierung durchführen, dann kannst du nur maximal 24 Stunden addieren. Danach fängt Calc wieder bei Null an. Für eine korrekte Addition benötigt man eine benutzerdefinierte Formatierung.

Bei der Standard-Formatierung Zeit zeigt Calc bei einer Summe von mehr als 24 Stunden nur die Überzähligen an. Im Klartext bedeutet das: Bei 36 Stunden werden lediglich 12 Stunden angezeigt.

Nur ein benutzerdefiniertes Zahlenformat sorgt hier für die richtige Stundenberechnung.

Markiere dazu die betreffenden Zellen und klicke mit der rechten Maustaste in die Markierung. Wähle im Kontextmenü die Option Zellen formatieren und rufe im Dialogfenster das Register Zahlen auf.

Im Bereich Kategorie klickst du auf den Eintrag Benutzerdefiniert, gibst bei Format-Code die Formel [HH]:MM ein und bestätigst die Änderung mit OK.

Ab sofort führt Open Office Calc die Stundenaddition korrekt durch.

Kategorien
Excel Hardware & Software

Excel Summe bilden: Summen über Spalten und Zeilen berechnen

Mit der Summenformel werden üblicherweise nur bestimmte Bereiche einer Tabelle summiert, mit der Formel =SUMME(A1;A20) zum Beispiel alles zwischen den Zellen A1 und A20. Kommen weitere Zeilen hinzu, beginnt die Arbeit von vorne. Erst wenn die Formel angepasst wurde, werden auch die neuen Zeilen berücksichtigt. Das muss nicht sein. Viel einfacher ist es, gleich die Summe über die gesamte Spalte oder Zeile zu bilden. Ob und wie viele Werte hinzukommen, spielt dann keine Rolle – die Summenformel zeigt stets das korrekte Ergebnis.

Eine Formel für die komplette Spalte oder Zeile

Um ganze Spalten oder Zeilen zu addieren, müssen Sie bei der Summenformel keinen Zellbereich, sondern zweimal hintereinander die Spalte bzw. Zeile eintragen. Zum Addieren aller Werte in Spalte C lautet die Formel dann

=SUMME(C:C)

Möchten Sie alle Werte in Zeile 41 summieren, genügt folgende Formel:

=SUMME(41:41)

microsoft-excel-summe-komplette-spalte-komplette-zeile